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Introduction and Overview 

I. Synopsis 
 
Explicet is a visualization software application that facilitates analysis of taxonomy-based microbiome datasets.  
The goal of the Explicet development process was to create a powerful, yet intuitive, software tool for exploring 
and displaying complex microbiome datasets.  Utilization of a graphical user interface (GUI) allows the user to 
concentrate on the science of a microbiome project, rather than the computational details. 
 
Explicet is multi-platform and is currently provided for Mac OS X (10.6, 10.7, 10.8), Windows (XP, Vista, 7, 8), 
and Linux (RHEL/CENTOS 5, 6).  Explicet is fully compatible with taxonomically classified microbiome 
datasets produced by bundled tools such as Qiime [1], Mothur [10], and XplorSeq [4]. 
 
Explicet uses taxonomic classifications derived from rRNA sequence data, combined with complete integration 
of project metadata, to produce tables and graphical plots (such as x-y charts, heatmaps, pie charts, and 
stacked bar charts) that portray the make-up of microbial communities from many perspectives.  Explicet 
includes the ability to calculate and graphically display statistical metrics of alpha and beta diversity such as 
Sobs, Chao1, Good’s coverage, and Morisita-Horn.  Additionally, Explicet includes several statistical 
computations (Two-Part, Two-Proportions, and Wilcoxon) that measure the statistical association between a 
given taxonomic classification type and a categorical variable (e.g., “healthy” and “sick”).  Explicet provides 
data management capabilities that allow a dataset to be subdivided by metadata, sample name, and/or 
taxonomy.  All tables and graphics generated by Explicet may be saved as named “figures” that can be 
recalled for modification. 
 
Graphics output by Explicet may be in either bit-map formats (such as .png) or vector formats (.pdf), which are 
readily imported by tools such as Microsoft Word, PowerPoint, and Adobe Illustrator.  Tables generated by 
Explicet are formatted as comma-separated-value files (.csv), which can be easily imported into Microsoft 
Excel, GraphPad, R, and SAS. 
 
Although developed to facilitate the analysis of rRNA sequence data, Explicet can also be used to analyze 
other count-based datasets with hierarchical structure (e.g., metagenomic data, gene sequences other than 
rRNA). 
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II. Why Use Explicet? 
 
By their very nature, microbiome datasets have many sub-components; often they contain data derived from 
many samples, with many sequences comprising each sample, many results derived from each sequence, and 
all associated with metadata that describe the nature of the samples and the hypothesized sources of 
variability in the results derived from the sequences (Figure 1).   
 

 

 
 

 
The manual, human-intensive effort required to manage the logistics of these complex datasets often 
significantly distracts from the scientific questions that prompted the study in the first place.  Although 
microbiome analysis tool frameworks like Qiime and Mothur have made it more tractable to transform raw 
sequencer data objects to data that can be operated on by statistical tools like SAS [9] or R [8], a significant 
burden is still placed on the user, because current generation tools are principally command line driven and 
give little intrinsic data management support.  Explicet was developed to ease the analysis of taxonomically 
classified microbiome datasets by providing metadata-driven data analysis and management capabilities from 
within a familiar and intuitive GUI.  Explicet’s capabilities pick up at the point in the data analysis process at 
which sequence data have been transformed (by means of the user’s preferred sequence analysis pipeline) to 
taxonomic classifications.  Once a project’s taxonomic and metadata components have been imported, 
Explicet can be used to subdivide the data by sample, metadata item value, and/or taxonomic attributes, and 
then apply a variety of analyses to the data.  Results can be displayed as tables or graphics (x-y plot, heatmap, 
pie chart, stacked bar chart, etc.) or can be exported in formats suitable for manipulation by dedicated 
statistical packages (e.g., SAS, R, SPSS).  Each project subdivision of interest can be stored in a separate 
workspace, all of which is contained in a single project file.  Each of the graphics can be saved as “figures” 
which are easily recalled from the top level of each project. 
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III. Terminology  

A. Descriptive Terms 
 

OTU:  An “Operational Taxonomic Unit” is a collection of related sequences that represent an organism 
or group of organisms.  In other words, the sequences define an OTU, the latter of which we believe to 
map onto a group of organisms. Explicet views numerical OTUs as interchangeable with classification 
OTUs.  
 
Metadata:  Information about a collection of data (e.g., sample type, GPS coordinate, pH, patient, 
disease status, age, weight, etc.).  
 
Library:  A set of OTUs derived from a discrete sample/specimen. 

B. Ecological Terms 
 

Biodiversity:  The degree of variation of life forms within a given ecosystem or biome.  Biodiversity 
often is measured by the following indices: 
 

Richness:  The number of different OTUs in a given environment.  
 Q:  How diverse is the sample?  
 
Complexity:  Diversity indices like Shannon and Simpson are attempts to quantify the number of 
types of organisms present while simultaneously measuring how all of the organisms in a sample 
are distributed among the types (the evenness of the sample). 
 
Evenness:  Quantifies how equally distributed are the OTUs in a library. 
 Q:  How evenly distributed are the members of the community?   
 Q:  Is there one dominant species, or are all species seen in the same abundance? 
 
Alpha Diversity:  The biodiversity within a particular sample; usually expressed as species 
richness.   
 
Rarefaction:  Process that randomly resamples all libraries to the sampling depth of the smallest 
library (called the rarefaction point), thus allowing the alpha diversity metrics to be compared 
directly. 
 
Beta Diversity:  The degree of overlap in biodiversity between two environments, or samples; 
involves comparing the number of taxa that are shared by two libraries.  
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IV. Data Management Capabilities in Explicet 
 
The fundamental data item in Explicet is the “project”, the data for which is stored in a single file.  Optionally, a 
project may have multiple derivations called “workspaces” contained within the same file, which typically are 
subsets of the data contained in the full project.  A project and its workspaces may have multiple figures 
(graphical or tabular representations of data).  Projects have direct access to all figures contained within each 
workspace. 
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V. Main Window Overview 
 

  
 
 
The main window of Explicet has three parts.  These are, from top to bottom: 
1. The classic graphical user interface pull-down menus consisting of File, Edit, Data, Group, Tools, View, 

and Help. 
2. The command and control cluster, used to display and select the options in effect for a project and 

workspace. 
3. One or two data display panes. 
 
The command and control cluster is organized into 8 columns (from left to right): 
1. The Project / Workspace / Current Filter column displays the name of the dataset, the name of the current 

workspace, and the name of a filter that can be used to select libraries within that workspace.  Note that the 
workspace line ends with a radio button that, if clicked, converts the text box into a drop down menu that 
allows the user to open or move to any workspace within the project. 

2. Selects which data display panes (described below) are displayed:  Hierarchy, OTU, or Both. 
3. Selects how the data is displayed within the Hierarchy and OTU panes.   Data can be displayed as Counts, 

% of Library (a.k.a. percent abundance), and % of Total. 
4. Allows the user to interactively control the detail in which OTU names are displayed within the OTU pane.  

OTU Start selects the first taxonomy category (counting from 1) to be shown. OTU Width determines the 
maximum number of categories shown.  The check box, OTU Show Last, can optionally force the terminal 
category on an OTU name to always be shown independent of the state of OTU Start and OTU Width.  
Setting OTU Width to zero, and checking OTU Show Last, causes display of only the terminal category for 
each OTU name. 

5. Hierarchy Level controls the default number of levels that are expanded in the Hierarchy column of the 
Hierarchy pane. 

 

1 

2 

3 

        
1 2 3 4 5 6 7 8 

1 

2 
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6. and 7.  These two columns together control how library data is to be displayed in the Hierarchy and OTU 
panes.   

 Show Libraries shows all of the active libraries in a worksheet.   

 Show Sorted Libs displays all libraries in a worksheet after sorting and annotating library names by 
metadata selected through the View → Sort Libraries function.   

 Show Lib Groups shows the groups active and selected by the Group → Group Library function. 

 All Libraries shows all libraries in the dataset. 

 Selected Libraries shows just the subset of libraries selected by the Current Filter. 

 The value shown below Selected Libraries shows the number of libraries selected when Selected 
Libraries is chosen. 

8. The four buttons in the eighth column (from top to bottom) allow the direct selection of figures created in any 
workspace in the project (Figures), a one click creation of a new workspace from the current workspace 
(Clone Workspace), a one click Save of all data within a project, and a one click shutdown of all 
workspaces in a project via Close Project (the user is first prompted to save any unsaved modifications to 
the project).  All active windows closed by Close Project will be re-opened exactly as shown when the 
project is re-started. 

 
Data display panes 
1. The Hierarchy Pane:  This pane allows the user to explore a data set in terms of hierarchical levels by 

which the user has organized the sequences in a dataset, such as Domain, Phylum, Class, Order, Family, 
Genus, and Species.  These categories are classifier dependent and need not be phylogenetic/taxonomic 
classifications (e.g., for non-16S rRNA datasets).  This pane shows a hierarchical summary of the data 
imported into the project, with levels selected as rows on the left side of the pane.  Initially, data are 
presented as sequence counts for particular taxonomic levels, displayed for all libraries (the column “Total”) 
or broken down library by library.   

2. The OTU Pane:  The left side of this pane shows an alphabetical list of all of the OTUs found in the data 
selected for the worksheet.  The “Total” column shows the representation of sequences in each OTU in all 
samples, and the rest of the pane presents data for individual libraries.  This pane displays the data that will 
go into the analysis functions of Explicet or other statistical tools such as SAS or R via the Export → OTU 
function. 
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VI. Project Flow 

 
The following outline represents a typical workflow for a project in Explicet.  For more detailed information on 
this process, please view the Explicet Tutorial.  The tutorial and associated data are obtainable from the 
website: www.wally.colorado.edu/Explicet   
 
 
 

  

Figure 3. Typical flow for a project in Explicet. 

Import Taxonomy Data for a Project 
See page 24. 

Import Metadata for the Project 
See page 28. 

Adjust the Display as Necessary 
Adjust display format (see page 31), sort data (see page 32). 

Create a Subset of the Project Data for a Specific Analysis 
Create a workspace (see page 36). 

Analyze Data and Save Figures 
Select data (see page 37), create figures (see page 43),  

run statistical tests (see page 50). 

Repeat from this Step Until Done 

Edit Figures 
To edit pre-existing figures, go  

directly to the desired figure and  
modify as necessary (see page 49).  

http://www.wally.colorado.edu/Explicet
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Copyright and GPL License 
 
Copyright © 2010-2013 Charles E. Robertson and Incubix, Inc. 
 
Contact:  charles.robertson@colorado.edu   
 
This program is free software: you can redistribute it and/or modify it under the terms of the GNU General 
Public License as published by the Free Software Foundation, version 3. 
 
This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the 
implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU 
General Public License provided in accompanying file Explicet-Copyright-GPLv3License.txt 
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Installation 

I. Microsoft Windows 

A. Install Package 
Explicet installer files 
Copyright and GPL license file 
Explicet handbook 
Explicet tutorial 
Explicet tutorial data: OTU import file 
Explicet tutorial data: metadata import file 
Release notes 

B. Supported Platforms 
Windows Vista, Windows 7, Windows 8: Explicet_Win64 
Windows XP: Explicet_Win32 

C. Installation 
Download the platform-appropriate installer: Explicet_Win64_##_Setup.exe (## is the version number) 
Open the containing folder of the download 
Double click on the Explicet setup file 

 
Follow the instructions on the Explicet Setup Wizard 

double-click 
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D. Explicet Documentation 
To access the Explicet documentation, click on Documents  
Double-click Explicet_User_Data to retrieve the Explicet handbook, tutorial, tutorial data 

 
 

  

double-click 
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II. Macintosh OS   

A. Install Package 
Explicet installer files 
Copyright and GPL license file 
Explicet handbook 
Explicet tutorial 
Explicet tutorial data: OTU import file 
Explicet tutorial data: metadata import file 
Release notes 

B. Supported Platforms 
Lion (10.7), Mountain Lion (10.8): Explicet_Mac64 
Snow Leopard (10.6): Explicet_Mac32 

C. Installation 
Download the platform-appropriate installer: Explicet_Mac32_##.dmg (## is the version number) 
Open the containing folder of the download 
Double click on the Explicet setup file 

  
A graphic will appear 
Drag the Explicet_Documents folder into the Users Shared folder 
Drag the Explicet icon into the Applications folder 

double-click 
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 Open Applications  

Double-click the Explicet icon to begin using Explicet 

   

drag 

double-click 

drag 
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D. Explicet Documentation 
To access the Explicet documentation, click on your hard drive 

 Double-click Users 

 
Double-click Shared 

 
Double-click Explicet_Documents to retrieve the Explicet handbook, tutorial, tutorial data 

double-click 

double-click 
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Documents 

double-click 
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III. Linux 

A. Install Package 
Explicet binary file 
Copyright and GPL license file 
Explicet handbook 
Explicet tutorial 
Explicet tutorial data: OTU import file 
Explicet tutorial data: metadata import file 
Release notes 

B. Supported Platforms 
Red Hat Enterprise Linux 5.x 
RHEL 6.x 
Centos 5.x, Centos 6.x 

C. Installation 
Place the Explicet application for Linux, Explicet-Linux64_X.X, in a folder after untarring it: 
 
tar –xvzf Explicet-Linux64_X.X 
 
Create a symbolic link to the Explicet compressed tar file in a folder known to be within the scope of the 
current path settings.  For example, assuming the Explicet Linux executable is in /home/chuck, first 
make sure the execute bit of the application is set: 
 
chmod +x Explicet-Linux-xxx-mmddyy.exe 
 
Now, as root (or via sudo), make a symbolic link: 
 
cd /usr/local/bin 

 
ln –s /home/chuck/Explicet-Linux64_X.X  /usr/local/bin/explicet 
 
Alternatively, add the Explicet application to the path, or simply start Explicet in the local directory by 
typing ./Explicet-Linux64_X.X. 
 
For subsequent installs, you may need to delete the pre-existing Explicet symbolic link. 
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Condensed Quick-Start Example 
 
The following guide presents a few quick examples of Explicet capabilities.  For a more thoroughly 
documented example on the Explicet project process, please view the Explicet Tutorial.  The tutorial and 
associated data are obtainable from the website: www.wally.colorado.edu/Explicet  

I. Import the OTU table. 
File → Import → File → OTU Table Counts 
A pop-up window will open, select “Tutorial_HSM_OTU_2_Explicet” 
Click Open 
Another pop-up window will open 
Click Import 

II. Import metadata for the OTU table. 
File → Import → Metadata 
A pop-up window will open, select “Tutorial_HSM_Metadata” 
Click Open 
Another pop-up window will open 
Click Import 
Another pop-up window will open 
Click Apply, then click Done 

III. Set the project name. 
Edit → Project Settings 
Enter “Tutorial_HSM” in the top line of the pop-up window 
Click Apply to name the project 

IV. Save the project. 
Click Save button in upper right corner of window 
A pop-up window will open 
Enter desired file name (default file name is project name with an “_Explicet_Project” extension) and location 
Click Save 

V. Create a pie chart. 
Tools → Plot → Pie Chart 
A new window will appear with the hierarchical data available in the workspace 
Holding “Shift”, select all of the classes (Acidobacteria through Verrucomicrobia) 
Click Add to Pie 
The OTU name changes to a bold font 
Click Plot 
A new window will appear containing pie chart display options 
To display a single pie chart that includes all libraries’ data, select the 30 Total Libraries checkbox 
Click OK to view the pie chart 
Click Done to return to the pie chart setup window 
Click Save As Figure in lower right corner of window 
A pop-up window will open 
Enter desired figure name 

http://www.wally.colorado.edu/Explicet
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Click OK 
Click Done to return to the main project window  
(The figure can always be recalled by clicking the Figures button in the upper right corner of the main window) 

VI. Create a workspace (a subset of libraries and OTU lines). 
File → New → Workspace 
Enter “Back” workspace name when prompted 
Click OK to create the new workspace 
 
Data → Select Libraries 
New pop-up window appears for creation of filters  
Click New on far right side of window 
Enter “Back” filter name when prompted 
Click OK 
“Back” appears in upper left corner of window 
Click Add on right side of upper pane 
Use the first pull-down menu to select “Anatomy” (metadata to filter by) 
Use the second pull-down menu to select filter “contains” (operator) 
Enter “back” into Value 
To apply filter, click Select in upper right corner of window 
Click Save Filter on far right side of window to keep the filter 
Click Done 
Select Selected Libraries on the upper right corner of the workspace window 
The workspace now only displays libraries sampled from the back.  

VII. Compute beta-diversity (heatmap of Morisita-Horn matrix). 
Tools → Analyze → Beta Diversity → Morisita-Horn 
A new window appears containing a comparison matrix with the calculated Morisita-Horn similarity values  
Select Selected Libraries in the upper left corner of the window 
Click Plot on lower right side of window 
A heatmap appears displaying a comparison of the OTUs between the “back” library samples 
Click Done to return to the heatmap setup window 
Click Save As Figure in lower right corner of window 
A pop-up window will open 
Enter desired figure name 
Click OK 
Click Done to return to the main project window  
(The figure can always be recalled by clicking the Figures button in the upper right corner of the main window) 

VIII. Create an x-y plot of Species observed, Sobs. 
Tools → Analyze → Alpha Diversity 
A new pop-up window will appear 
Click Bootstrap on upper right side of window 
Click Plot on lower right side of window 
A pop-up will appear with all the diversity measures and library names 
Select Sobs (the number of OTUs observed in a library) 
Click OK 
A plot of the rarefaction curves for the selected measures and libraries will appear 
Click Done to return to the alpha diversity setup window 
Click Save As Figure in lower right corner of window 
A pop-up window will open 
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Enter desired figure name 
Click OK 
Click Done to return to the main project window  
(The figure can always be recalled by clicking the Figures button in the upper right corner of the main window)  
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Comprehensive User Guide 

I. Import OTU Data 
 
The Explicet program provides a GUI for exploring OTU data, but does not generate the OTU data.  Rather, 
taxonomic data for a project can be imported from a variety of sequence processing software programs 
including the RDP Classifier [2], ARB NDS [5,7], Mothur [10], and Qiime [1], and in multiple formats.  Data 
import is fully incremental, so data may be imported at any time. 
 
Note: The import format, date, time, and file location of OTU data are logged in Edit → Project Settings. 

A. OTU Data File Format 
The import file must be a delimited file (i.e., delimited by tabs, commas, or spaces). 

B. Import a File 
An import file contains multiple libraries (a.k.a. samples) in a single file.  
 
File → Import → File →… 

1. Three-line (legacy) 
One file with three lines for each OTU result:  

(line 1) library name and sequence name separated by a tab  
(line 2) this second line is ignored  
(line 3) OTU names separated by slash/tab/semi-colon/colon/comma/period/space 
 
Example: 
TPN0001B <tab> TPN0001B_000001 
A 
/Root/Bacteria/"Bacteroidetes"/"Bacteroidia"/"Bacteroidales"   

2. Two-line (fasta style) 
Requires two files... 
 
File 1 = file with two lines for each OTU result:  

(line 1) >sequence name 
(line 2) OTU names separated by slash/tab/semi-colon/colon/comma/period/space  
 
Example: 
>TPN0001B_000001 
/Root/Bacteria/"Bacteroidetes"/"Bacteroidia"/"Bacteroidales" 

 
File 2 = file mapping sequences to libraries, with one line for each OTU result:  

(line 1) sequence name and library name separated by a tab 
 
Example:  
TPN0001B_000001 <tab> TPN0001B  
 
Note: It is the user’s responsibility to create the mapping file, for instance using a spreadsheet. 

3. One-line (ARB NDS) 
Requires two files... 
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File 1 = file with one line for each OTU result - such as that emitted by the NDS export function of 
ARB:  

(line 1) sequence name and OTU name separated by a tab 
 
Example: 

 TPN0001B_000001 <tab> /Root/Bacteria/"Bacteroidetes"/"Bacteroidia"/"Bacteroidales" 
 
File 2 = file mapping sequences to libraries, with one line for each OTU result:  

(line 1) sequence name and library name separated by a tab 
 
Example: 
TPN0001B_000001 <tab> TPN0001B 

 
Note: It is the user’s responsibility to create the mapping file, for instance using a spreadsheet. 

4. RDP Classifier 
Explicet handles both local and web formats. Requires two files... 
 
File 1 = file with one line for each OTU result:  

(line 1) sequence name and OTU name with bootstrap scores 
 

This file is formatted as exported by RDP.  Please reference the website for more information: 
http://rdp.cme.msu.edu/index.jsp 
 
Upon import, the user has the option to change the Bootstrap Threshold for the OTUs being 
imported.  The import default on Explicet is 80%.  For more information on recommended 
bootstrap scores, visit the RDP website listed above.    

 
File 2 = file mapping sequences to libraries, with one line for each OTU result:  

(line 1) sequence name and library name separated by a tab 
 
Example:  
TPN0001B_000001 <tab> TPN0001B  
 
Note: It is the user’s responsibility to create the mapping file, for instance using a spreadsheet.. 

5. OTU Table Counts 
This is the most compact and efficient way to import OTU files.  Instead of listing each individual 
sequence, this is one file which contains each OTU name listed once and a count for each time it 
appears in each library:   

(top line) library names as column headings separated by a tab 
(following lines) OTU name and library counts separated by a slash 
 
Example: 
OTU Name <tab> Total <tab> HV1-1-BtRSc <tab> HV10-BtRSc <tab> HV2-1-BtRSc 
root <tab> 9,049 <tab> 326 <tab> 198 
Bacteria <tab> 2 <tab> 2 <tab> 0 
Bacteria;Acidobacteria;Acidobacteria;RB41 <tab> 1 <tab> 0 <tab> 0 
 
Note: OTU table count files are exported from Explicet, Mothur, and Qiime. 

C. Import a Directory 
A directory contains a separate file for each library.   The names of each file (less the file extension) will 
be used as the library name for the sequences within the file. 
 
File → Import → Directory →… 

http://rdp.cme.msu.edu/index.jsp
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1. Two-line (fasta style) / One-line (ARB NDS) / RDP Classifier  
Each individual file is formatted as described above in “Import a File”; however, each file name (less 
the file extension) is the library name (instead of a mapping file). 
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II. Edit Libraries 
 
A library is a set of OTUs that represent the results of classifying sequences derived from a discrete 
sample/specimen. 

A. Rename Libraries 

1. Import a File  
To rename many libraries at once, import a file that remaps the current names of libraries.  The file 
should contain one line for each sequence, OTU name.  The import file containing the new library 
names must be a delimited text file (sequence name and library name separated by a tab). 

 
Example: 
Sp02z56_00034 <tab> Sp02z56 (re-maps sequence Sp02z56_00034 to library Sp02z56) 

 
Data → Rename Libraries 
Select rename library file 
Click Open  

2. Edit in Metadata 
Instead of importing new library names from an outside source, the user can edit library names from 
within Explicet.   
 
Data → Metadata 
Click on the library name in the Assigned Metadata pane 
Type over the existing library name  
Click Apply to keep the changes to the library name 
Click Done to return to the project 

B. Remove Libraries 
Removing libraries is a permanent change to any project! 
 
Data → Remove Libraries 
A pop-up window will open 
Click on library name in left panel to select 

 Several libraries can be selected for removal by clicking the first library, then Shift-click on the last 
library.  Non-sequential libraries may be selected (or deselected) via Ctrl-click. 

Click Remove button between panels 
Repeat until all undesired libraries are moved to the right panel 
Click Remove in upper right corner of window 
A pop-up message will appear to warn you that you are about to delete data 
Click OK to remove libraries 
 
Note: The deletion date, time, and name of a removed library are logged in Edit → Project Settings.  
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III. Metadata 
  

Metadata is information about the source of the DNA sequences (e.g., GPS coordinates, pH, patient, disease 
status, age, weight).  

A. Metadata File Format 
The top row must be labels that are the names of the metadata categories for the project (e.g., library, 
specimen, time).  One column must be library names exactly as they appear in the OTU file.  This 
column maps the library names to the metadata values for that library. The column position of the 
library names within the metadata file does not matter, but the column must be present. The column 
fields must be delimited by either tabs, commas, or spaces.  

B. Import Metadata 
Metadata import is fully incremental, so new metadata may be loaded at any time during the life of the 
project. 
 
Note: The import date, time, and file location of metadata are logged in Edit → Project Settings. 
 
File → Import → Metadata 
Select file 
Click Open 
A pop-up window will open 
The upper left pane of the window shows the metadata fields found by Explicet in the metadata file 

 When Libraries not found is selected, any existing project libraries that are not also found in the 
metadata file appear in the upper right pane.   

 When Libraries found is selected, all project libraries that are found in the metadata file appear 
in the upper right pane. 

 By default, Add missing libraries to the project is deselected so that metadata doesn’t force 
empty libraries into projects.  By selecting Add missing libraries to the project, new libraries will 
be created in the project and populated with imported metadata.  Since there are no sequences 
associated with these libraries, the data columns will be filled with zeros in the hierarchy and OTU 
panes.    

 Metadata in the selected file that does not match the format of metadata already in the project 
appears in the bottom pane.  For example, if “Age” is a metadata category containing numerical 
data, attempting to import text data into the “Age” category will be noted in the bottom pane.    

In upper left pane, select the column which contains the library name 
Click Import  
 
A new pop-up window will open which displays the imported metadata.  This window can be re-
accessed via Data → Metadata. 

C. Add New Metadata 
Instead of importing metadata from an outside source, the user can create new metadata from within 
Explicet.   
 
Data → Metadata 
A window with three sections will open 

 The left pane: Defined Metadata, the right pane: Assigned Metadata, the bottom area: 
Metadata Definition.  The bottom section, Metadata Definition, allows creation of new metadata 
fields. 

Enter the desired name of the new metadata category next to the box labeled Name 
Choose the Type of metadata from the drop down menu 

 String that may be more than 8 characters: words or strings of text longer than 8 characters 
(e.g., umbilicus)  

 String that is 8 characters or less: words or strings of text 8 characters or less (e.g., male)  
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 64 bit Integer: whole number/number with no fractional part (e.g., 21, 4, or -2) 

 Double precision number: number with a fractional part (e.g., 3.75 or 5.5) 
(optional) For integers or numbers, an upper and lower bound can be defined… 
(optional) If there are only a few, distinct metadata values for the new definition, enter them as 
enumerated values; type each value under Enumerated Values, and click Add Value 

 To remove an enumerated value, select the value and click Remove Value. 

 To clear all enumerated values for a particular definition in one click, click Clear Values. 
Click Add in bottom right corner to add the new metadata definition to Defined Metadata list 
Select new metadata definition in the Defined Metadata pane 
Click Add button between panes to add it to Assigned Metadata  
For each library in the Assigned Metadata pane, enter the corresponding value 

 If Enumerated Values were entered, the values will appear in a drop down menu for each library. 

 To fill values for multiple libraries at once, use the Copy and Paste functions. 

 To select whole rows, click on the first value to select, then Shift-click on the last value; to select 
whole columns, click on the title of the column.  Click the Copy button (the values are copied to 
an internal clipboard).  To paste the copied values to other cells, select the cells you want to paste 
to, and click the Paste button.  Note: If the clipboard contains a multi-row and/or multi-column 
selection, the number of rows and columns to paste to must match the number of rows and 
columns copied to the clipboard.  If they don't match, an error message will appear, and nothing 
will be copied. 

 To copy one value to multiple cells, select the cell to copy, click Copy.  Select the cells to paste 
to, click Paste. 

Click Apply to keep the changes; click Done without clicking Apply to discard the changes 
 
Note: All operations are performed on the selected libraries displayed in the Assigned Metadata pane.  
You can show All Libraries in this pane or click the Selected Libraries radio button to operate on the 
libraries chosen by the current workspace filter. 

D. Modify Current Metadata 
To set or change values in the Assigned Metadata pane, click on the value to change, and type in a 
new value.  If the metadata values are enumerated values, a drop down from which to pick one of the 
Enumerated Values will appear. 
 
To modify an existing metadata definition, click on it in the Defined Metadata pane.  Its definition will 
show in the box labeled Metadata Definition.  Make any desired changes; change the Name, the 
Type, add Upper/Lower Bounds, or add Enumerated Values, then click Replace.  Keep the changes 
by clicking Apply.  
 
To create new metadata from existing metadata, select the metadata in the Defined Metadata pane.  
The name MUST be changed.  Then make any other changes to Type, Bounds, or Enumerations, 
and click Add. 
 
Note: All operations are performed on the selected libraries displayed in the Assigned Metadata pane.  
You can show All Libraries in this pane or click the Selected Libraries radio button to operate on the 
libraries chosen by the current workspace filter. 

E. Export Metadata 
Metadata is exported as a tab-delimited (.txt) file.  There are 2 different ways to export metadata: 
1. File → Export → Metadata 

Enter desired metadata output file name and location 
Click Save 

2. Data → Metadata 
Click Export in upper right corner of pop-up window 
Enter desired metadata output file name and location 
Click Save 
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F. View Metadata 
Data → Metadata 
 
A window with three sections will open.  The left pane, Defined Metadata, has the libraries and 
columns describing each metadata point associated.  The right pane, Assigned Metadata, has the 
metadata titles.  The bottom area, Metadata Definition, allows you to create new metadata fields 
(instead of importing them from elsewhere).   

G. Remove Metadata 
Data → Metadata 
A pop-up window will appear 
Select unwanted metadata column in the right, Assigned Metadata, pane of the window  
Click Remove button between panels 
A pop-up message will appear to warn you that you are about to delete data 
Click OK to remove metadata  
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IV. Display 

A. Hierarchy, OTU, or Both 

1. Hierarchy 
In Hierarchy mode, the data collapses into OTUs with triangular expansion buttons. Clicking on an 
expansion button expands the selected taxonomic level to the next lower level.  This generates an 
easy-to-read display that can be expanded and compressed to investigate comparisons between 
libraries or metadata groups.  The number of items in the lineage lines is determined by the input file, 
i.e. the depth of classification during pipe run on raw sequence data.  Clicking on the OTU category 
will highlight the line across the entire dataset.  Hierarchy Level (see page 32) sets the default of 
how many levels of hierarchy are displayed. 

2. OTU 
In OTU mode, each taxonomic classification is listed individually, often resulting in very long OTU 
names that use large amounts of screen space.  To make the data more tractable in this setting, use 
the OTU Start, OTU Width, and OTU Last functions (see page 31 for details).  The number of 
categories in the lineage lines is determined by the input file, i.e., the depth of classification provided 
by the classification analysis tool run on the raw sequence data.  Clicking on the OTU name will 
highlight the line across the entire dataset. 

3. Both 
Selecting Both creates two panes on the workspace screen. The upper pane shows the Hierarchy, 
and the lower pane shows the OTUs. 

B. Raw and Normalized Data Options 

1. Counts  
This option shows the raw sequence data counts (integers). 

2. % of Library 
Data is normalized by column (library or metadata grouping). This is generally the most useful 
setting for comparing sequence distributions between samples or groups of samples. 

3. % of Total  
Data is normalized to the entire OTU count for the total dataset. 

C. OTU displays 

1. OTU Start 
This allows the user to control the taxonomic level at which to start the lineage lines in the OTU pane 
display.  For example, rather than every sequence starting at the domain level 1 for domain 
(Bacteria/Eukarya/Archaea), the user can select OTU Start at level 2 for phylum 
(Acidobacteria/Proteobacteria/etc.), or at level 3 for subphylum 
(Alphaproteobacteria/Betaproteobacteria/etc.).   

2. OTU Width  
This option limits the number of taxonomic categories displayed in the OTU name.  The number of 
taxonomic categories can be selected by entering the desired taxonomic levels to display.  For 
example, setting OTU Start at level 1, and OTU Width at 3, would produce the following:  
“Bacteria/Proteobacteria/Alphaproteobacteria…” 

3. OTU Show Last 
This option appends the last item in the taxonomic line onto an OTU name, independent of the 
values of OTU Start and OTU Width.  The depth of taxonomic classification is determined by the 
input file. In the example above, OTU Show Last could be the genus level:  
“Bacteria/Proteobacteria/Alphaproteobacteria…/Paracoccus” 
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All OTU names can be forced to display ONLY the terminal category by checking this option and 
setting OTU Width to zero.  One item OTUs (such as OTU Group names or OTUs that can only be 
traced to kingdom level, like “Bacteria”) are considered the last OTU position; single name OTUs will 
disappear when OTU Show Last is deselected. 

D. Hierarchy Level 
Sets the default number of taxonomic levels expanded in the hierarchy pane.  

E. Libraries 

1. Show Libraries 
This option will display the libraries by name and sort them alphabetically by name (e.g., AL123, 
EM321, RA964) from left to right. 

2. Show Sorted Libraries 
Sorted libraries have one or more metadata tag(s) pre-appended before the library name, separated 
by a colon. The libraries are then displayed alphabetically first by metadata tag(s), then by library 
name. This option allows the user to sort the library columns by metadata while still seeing all 
individual names as well (e.g., City1:AL124, City1:RA964, City2:EM321).   Often libraries and 
sequences are named with obscure codes, this mechanism allows the introduction of human 
readable text which may ease the interpretation of the project data.  This human readable metadata 
is carried forward into all of the analyses and graphical displays within Explicet. 

a) Sort Libraries 
View → Sort Libraries  
A pop-up window will open  
In left panel, select the metadata descriptor you wish to sort by 
Click Add button between panels 
Name of metadata descriptor will appear in the right panel 

 To change the sort order of an individual metadata, click on the current Sort Order value 
(ascending/descending), and select the desired sort order from the dropdown menu.  

Click Sort at top right of window to accept library sorting 

b) Remove Library Sorting 
If you wish to remove a library sorting, follow the same procedure, except select the undesired 
metadata field in the right panel and click Remove button between panels. 

3. Show Library Groups 
This option displays the results of creating groups of libraries with the Group Libraries command.   
Groups are formed by selecting libraries based on a common metadata field.  The relative 
abundances of each selected library are averaged to form the values for the group.  The Counts 
values displayed for groups is computed by using the averaged relative abundances for each 
taxonomic categories.  For more information on how the Counts in library groups are calculated, and 
to create library groups, see page 37, “Group Data”.  

4. All Libraries 
This option shows all libraries in the workspace, and the display is arranged according to the Show 
Libraries / Show Sorted Libs / Show Lib Groups selection.  

5. Selected Libraries 
It is often desired to look at a subset of the libraries within a project.  In Explicet, this is done by first 
creating a filter, then using the Selected Libraries mode.  In this mode, the user can examine data 
only from the libraries of interest (based on the criteria set in the filter), instead of from the entire 
dataset.  Whereas Sort Libraries simply rearranges the view layout, Select Libraries excludes data 
from the view.    Select Libraries is often used in conjunction with the creation of a separate 
workspace for the libraries of interest.  For a description of how to select libraries, see page 37, 
“Select Libraries”. 
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F. Sort OTUs 
Sorting OTUs will arrange the data columns in the OTU pane by ascending or descending OTU 
abundance. 

1. Sort OTU 
Click on the library name in the OTU pane to sort by descending order based on the contents of that 
column (or Total).  A small arrow will appear above the column title which indicates sort order.   
 
Click the library name again to flip the sort order.  The small arrow above the column title will switch 
to pointing upward, indicating that the OTU pane has been sorted in ascending order based on the 
contents of that column (or Total). 

2. Remove OTU Sorting 
There are 3 different ways to restore alphabetic sorting of the OTU pane: 
1. Double click on the library name or Total 
2. Hold Ctrl-click on the library name or Total 
3. View → Unsort OTU 
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V. Projects 
 

Projects differentiate between various datasets (e.g., different studies) or between different versions of the data 
(e.g., different methods of assigning OTU names).  Projects provide an organizing mechanism for user’s data: 
both the OTU data and associated metadata.  Each project is a single data file.  The name of the current 
project is displayed in the upper left corner of the main window. Users may choose to use the data 
management capabilities of Explicet, which are shown in Figure 2 (page 9).  As shown in the figure, projects 
may contain one or more workspaces.  Workspaces are generally made up of subsets of the data contained in 
the full project and are wholly contained within the project.  Projects and workspaces contain figures, which are 
tabular and/or graphical representations of data (e.g., a graph of species observed, Sobs, for the data in a 
project or workspace).  All figures created within a project and its workspaces are globally available from the 
project or any workspace created within that project. 

A. New Project 
File → New → Project 
Enter desired project name when prompted 
Click OK to create the new project 

B. Copy of Project 
Clones all project-associated data, including OTU tables, filters, and figures.  
 
File → New → Project from Current Project 
Enter desired project name when prompted 
Click OK to create a copy of the current project 

C. Open Existing Project 
File → Open → Project 
Select file 
Click Open to open project 

D. Name or Rename Project 
Edit → Project Settings 
Enter new project name (or type over existing name) in the top line of the pop-up window 
Click Apply to rename current project 

E. Save Project 
There are 2 different ways to save a project: 
1. Click the Save button in upper right corner of any workspace window.  
2. File → Save / File → Save As  

 
Note: Quick keys (e.g., Ctrl-s) are not currently supported in Explicet.  Explicet does not auto-save, so 
remember to save often!  

F. Close Project 
There are 3 different ways to close out of Explicet: 
1. Click the Close Project button in upper right corner of any workspace window. 
2. File → Close → Project 
3. File → Exit 
 
Note: If you close a project with multiple workspaces open, the project is saved as-is.  The next time 
you open the project, all workspaces will open exactly as in the previous session.   

G. Project Settings 
Project Settings provides a nice layout summarizing all of the project components. 
 
Edit → Project Settings 
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 Edit the Project Name.  

 If the current project is one of several different versions or one of several different studies on the 
same data, you can record the Project Version number. 

 Record Comments about the project’s specific aims, trends, notes, etc.  

 When Do not import Libraries whose total count is zero is selected, any libraries with no 
members (e.g., the total number of OTUs in the library is 0) will not be added to the project.   

 Projects may have libraries with no members if Do not import Libraries whose total count is 
zero is not selected. However, the libraries can be eliminated from computations if you pick the 
Filter out Libraries whose total count is zero option. In other words, if a library has no 
members, and Filter out Libraries whose total count is zero is selected, the library will not 
appear in the workspace window, Alpha Diversity, Beta Diversity, etc. 

 By default, Explicet appends an “_Explicet_Project” extension to filenames in order to help 
distinguish a project file from other files.  This default can be removed by deselecting Append 
“_Explicet_Project” to Filename. 

 Edit the Column delimiter for Export (character(s) placed between columns); delimiter may be 
up to 6 characters, enter “tab” for tab. 

 Adjust the # of Decimal Places for Percents in OTU displays.    

 View the date and time the project was created. 

 View the date and time the project was last saved. 

 View the quantity and names of the project’s associated Workspaces, Filters, Figures, 
Metadata tags, and Libraries. 

 The bottom pane (labeled Imports) tracks all major edits to the project data, including: OTU data 
imports, metadata imports, deletion of libraries, deletion of OTU lines. 

Click Apply to keep the changes  
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VI. Workspaces 
 

Workspaces allow the user to analyze subsets of the data that make up a project.   For example, if a project 
contains data from patients of different ages, several workspaces could be set up to handle specific age 
ranges.  Similar to figures, workspaces are saved within the larger project, so they stay linked to the data from 
which they were created and do not create additional computer files.  
    
Selected libraries (selected via filters) are saved to the larger project, but separate filters can be applied to 
different workspaces.  For a description of how to select libraries, see page 37, “Select Libraries”.   
 
Library data may be combined into groups, which are local to the workspace in which they were created.  To 
group libraries, see page 38, “Group Libraries”.   
 
Note: Libraries deleted from any workspace are also deleted from the larger project!  

A. New Workspace 
File → New → Workspace 
Enter desired workspace name when prompted 
Click OK to create the new workspace 

B. Copy of Workspace 
There are 2 different ways to create a copy of a workspace: 
1. File → New → Workspace from Current Workspace 

Enter desired workspace name when prompted 
Click OK to create a copy of the current workspace 

2. Click Clone Workspace button in upper right corner of any workspace window.  

C. Open Existing Workspace 
File → Open → Workspace 
Select workspace, click OK to open workspace 

D. Change Workspace 
Click the radio button next to the dialog box on the toolbar 
Click on the current workspace name 
Select a different workspace from the drop-down list 

E. Rename Workspace 
Type over the existing workspace name in the dialog box on the toolbar 

F. Remove Workspace 
File → Delete Workspace 
Click OK to remove current workspace 

G. Close Workspace 
There are 2 different ways to close out of a workspace: 
1. File → Close → Workspace 
2. Click the red “X” in the upper corner of the workspace window 
 
Note: Closing the final workspace window will close out of the entire project.  
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VII. Select Data 

A. Select Libraries  
This function allows the user to select subsets of libraries via library names (or portions of library 
names), metadata, and/or specific OTUs.  Library selection is often used in conjunction with 
workspaces to enable analysis of subsets of data within a project.  A workspace may have ONE current 
filter; to create a new subset, a new workspace with a different current filter must be created.   
 
Data → Select Libraries 
New pop-up window appears for creation of filters  
Click New on far right side of window 
Enter desired filter name when prompted 
Click OK 
Filter name will appear in upper left corner of window 
 
The popup window has three panes.  The upper pane is for creating filters based on metadata and 
library names (column filter), and the middle pane is for selecting OTUs (row filter)...   

1. Create a Library or Metadata Filter (Column Filter) 
Click Add on right side of upper pane 
Use the first pull-down menu to select metadata to filter by 
Use the second pull-down menu to select filter operator 
If one criterion does not include all the desired libraries, select Add again 

 Another criterion can be added to the filter using the And/Or function. 
To apply filter, click Select in upper right corner of window 

 When a selection is made, the number of libraries and the library names included in the filter 
will be displayed at the bottom of the popup window. 

Click Save Filter on far right side of window to keep the filter 

2. Create an OTU Filter (Row Filter) 
Click Add on right side of middle pane 
Type in the OTU name you wish to filter by (any level of the hierarchy) 
Use the first pull-down menu to select whether to filter by OTU name or member count 
Use the second pull-down menu to select filter operator 
Multiple OTUs can be filtered by using Add function 

 Another criterion can be added to the filter using the And/Or function. 
To apply filter, click Select in upper right corner of window 

 When a selection is made, the number of libraries and the library names, and the number of 
hits in the selected OTU will be displayed at the bottom of the popup window. 

Click Save Filter on far right side of window to keep the filter. 
 
The way to think about how library selection and OTU selection work together is that FIRST a library 
is selected with the Metadata Selection Criteria rules, and then SECOND the OTUs for inclusion 
within a selected library are chosen with the Taxonomy Selection Criteria filter.  In other words: 
OTU selection filters do not select or influence the selection of libraries; they only select the OTU 
values to be retained within libraries that are selected by the Metadata Selection Criteria. 

B. Group Data 
Explicet allows the data making up multiple libraries to be combined by averaging the relative 
abundances of included taxonomic categories.  For example, one might want to compare all libraries 
obtained by sampling within a building (Group 1) with all libraries within the study resulting from outdoor 
samples (Group 2).   Explicet assumes that a library is the set of results that represent all taxonomic 
results from a single sample.  To combine libraries without introducing a bias associated with large 
differences in within-group library sample sizes, Explicet combines libraries by averaging the relative 
abundances for each OTU in each library.  In Explicet, when grouped libraries are displayed as 
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“counts”, the Counts displayed are computed backwards from the summed percent abundances for 
each taxon. Results for the OTUs, especially for those OTUs with small number of counts, or OTUs 
whose counts vary widely between the grouped libraries, may be higher or lower than one expects from 
knowing the raw sums of the counts that went into the groups.  Users need to be aware of the statistical 
implications of any operations performed on grouped libraries, as the operations are performed on the 
averaged relative abundances, or imputed sequence counts, rather than the raw sequence counts. 

1. Group Libraries 
This function allows the user to assemble libraries into a larger category by shared metadata 
features (e.g., multiple libraries from the same patient or from multiple sites of the same chemistry).   

 
Group → Group Libraries  
A pop-up window will open  
In left panel, select the metadata descriptor you wish to group by 
Click Add button between panels 
Name of metadata descriptor will appear in the right panel 

 By clicking on the column titles (Metadata, Sort Order), a small arrow will appear which 
indicates sort order. Clicking on the column title a second time will flip the arrow/sort order.  

 For metadata that are numbers, a bin size can be specified by clicking on the number in the 
Bin Size column and entering the desired size.  For example, age metadata can be binned by 
5, resulting in group names like 0-5, 5-10, 10-15. 

Click Group at top right of window to accept grouping 
 
In the main workspace, make sure the Show Lib Groups check box is selected.  Columns should 
now have metadata groupings rather than library names. 

a) Remove Metadata Group 
If you wish to remove a metadata grouping, follow the same procedure, except select the 
undesired descriptor in the right panel and click Remove button between panels. 

2. Group OTUs 
Often it is desirable to use a more basal taxonomic category than that provided by the employed 
sequence classification software.  This is easily done in Explicet by forming a new taxonomic 
category combining several individual categories.  Explicet does not control the taxonomic 
categories that are combined, meaning any OTU name can be combined with any other OTU name 
(user beware).  For instance, the group function can be used to create an arbitrary “Other” taxonomic 
category consisting of disparate OTUs.  Grouping taxonomic categories is done within the OTU 
pane.  Combining OTUs is performed by Explicet by summing the raw counts of all of the OTU lines 
selected for the group.  Group OTU simply adds the raw counts together for each item in the group, 
UNLIKE Group Libraries. 
 
There are two components to grouping OTU names: OTU Groups and OTU Rule Sets.  Multiple 
OTU Groups, or a single OTU Group, may make up one OTU Rule Set. Every OTU Group must be 
part of an OTU Rule Set. Therefore, when creating a new OTU Group in a workspace, the user is 
required to create a new OTU Rule Set. Once an OTU Rule Set is established in a workspace, the 
user can add new OTU Groups or edit the existing ones in the current OTU Rule Set.   
 

a) Create OTU Group and OTU Rule Set 
Select the OTUs to combine 

 Several OTUs can be selected by clicking the first OTU, then Shift-click on the last OTU.   

 Non-sequential OTUs can be selected (or deselected) via Ctrl-click. 

 Select a single OTU line to create a consistent grouping rule, such as grouping all OTUs 
that start with the same name. 

Group → Group OTU 
A new window appears 
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Enter desired OTU Rule Set Name and Group Name where prompted 

 In a workspace which already has an active OTU Rule Set, the user cannot edit the OTU 
Rule Set Name.  Adding a new group simply creates a new OTU Group within the current 
OTU Rule Set; click Save to save the new OTU Group to the current OTU Rule Set.  

 Click Save As to make no changes to the original OTU Rule Set while also saving a copy 
of the current OTU Rule Set with the new OTU Group; if the user clicks Save As, a pop-
up will appear for entering a new OTU Rule Set Name.   

 To create a consistent grouping rule, enter the rule under Group All Taxonomies that 
Start with.  For example, to group all OTUs of the Bacteroidetes phylum, type 
Bacteria/Bacteroidetes under Group All Taxonomies that Start with.  

Click Save 
The pop-up will disappear 
The group name appears alphabetically in the OTU table (its members removed from the table) 
 
When OTUs are grouped, OTU names included in the group can be viewed by hovering your 
cursor over the group name.  
 
OTU groupings are available in the OTU Heatmap function, but not in the Pie Chart function.  
Any and all OTU Groups that are created will be carried forward into the analyses performed, 
and graphics created, within the workspace in which the grouping was done. 
 
Note: One item OTUs (such as OTU Group names or OTUs that can only be traced to kingdom 
level, like “Bacteria”) are considered the last OTU position; single name OTUs will disappear 
when OTU Show Last is deselected. 
 
For information on exporting OTU Rule Sets, see page 41. 

b) Add Single OTU Name to Existing OTU Group 
Select the OTU name to be added 
Ctrl-click the group name in the OTU table 
Group → Add OTU Names to OTU Group 
The individual OTU name will be removed from the OTU table and added to the OTU Group 
 
Note: While single OTU names can be added to an existing OTU Group, two or more OTU 
Groups cannot be grouped.  

c) Remove OTU Group 
Select the group name in the OTU table 

 If nothing is selected, all groups in the OTU table will be ungrouped. 
Group → Ungroup OTU 
A new window appears 

 Click Save to simply remove the OTU Group from the current OTU Rule Set.   

 Click Save As to make no changes to the original OTU Rule Set while also saving a copy 
of the current OTU Rule Set without the selected OTU Group; if the user clicks Save As, a 
pop-up will appear for entering a new OTU Rule Set Name.   

Group name is removed from the OTU table; its members are re-added to the table  

d) Remove Single OTU Name from Existing OTU Group 
Select the group name in the OTU table 
Group → Remove OTU Names from OTU Group 
A pop-up will appear with a list of OTU names within the OTU Group 
Select the OTU name to be removed 
Click Remove 
Click OK 
The pop-up will disappear 
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The OTU name will be removed from the OTU Group and added back to the OTU table 

e) Rename OTU Group 
Select the group name in the OTU table 
Group → Rename Group 
Enter new OTU Group Name where prompted 
Click OK 

f) Edit OTU Rule Sets 
Group → Edit OTU Rule Sets 
A window will appear with a list of all available OTU Rule Sets 
Select the OTU Rule Set of interest 

 There are several different ways to view an OTU Rule Set definition: 
1. Click View 
2. Double-click on an OTU Rule Set name 
3. Ctrl-click the OTU Rule Set button on the OTU pane.   
4. To view an OTU Rule Set definition and its members: simply left-click the OTU Rule 

Set button on the OTU pane to view both the definition and a list of the OTU Group 
members within the workspace in which the button was clicked.  In this list, a “!!” in 
blue in front of an OTU name means the OTU name is not a member of the current 
workspace. 

 Click Merge to join multiple OTU Rule Sets.  Using Shift-click or Ctrl-click, the user can 
select two or more OTU Rule Sets from the OTU Rule Sets column, and then click 
Merge.  A pop-up window will appear for creating a new name for the merged OTU Rule 
Set; OTU Rule Sets will be combined into a new OTU Rule Set, however, the 
original/individual OTU Rule Sets will still remain in the list.  

 Click Delete to remove an OTU Rule Set from the project.  

 Click Rename to change the name of an OTU Rule Set.  

g) Workspace OTU Rule Set Manager 
This function provides a simple way of managing which OTU Rule Sets are applied to which 
workspaces.  The user can assign only one OTU Rule Set to each workspace, but multiple 
workspaces can have the same OTU Rule Set. 
 
Group → Workspace OTU Rule Set Manager 
A window will appear with two columns 

 The list of workspaces, on the left, is static and un-editable.  The column of OTU Rule 
Sets, on the right, consists of drop-down selectors with all possible OTU Rule Set options 
next to each workspace.  

Adjust which OTU Rule Sets are applied to each Workspace as desired 
Click OK 
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VIII. Import/Export Workspace Rules 

A. Filters 
Instead of creating filters from scratch in each project or workspace, importing/exporting filters allows 
the user to share filters between projects.   

1. Import 
By importing filters, filter rules created in a different project can be transferred to a new project, 
preventing the user from needing to create new filters with the individual rules from scratch. 
 
File → Import → Filters 
Select file, click Open 
 
The filters now exist in the available filters list.  For more information on how to create and select 
filters, see page 37, “Select Libraries”.    

2. Export 
To export filters, first create filters with the conditions exactly as you wish you export.  This function 
exports all filters in the project.  
 
File → Export → Filters 
Enter desired filter output file name and location 
Click Save 

B. OTU Rule Sets 
Re-creating a desired grouping for every new project can be a tedious process.  Importing and 
exporting OTU Rule Sets automates the preservation and transfer of OTU groupings from project to 
project. 

1. Import 
By importing OTU Rule Sets, the specifications used to create OTU groups in a different project can 
be transferred and applied to a new project.  
 
File → Import → OTU Rule Sets 
Select file, click Open 
 
The OTU Rule Sets now apply to the current project, and the OTU Groups will appear in the OTU 
table, grouped accordingly. For more information on how to remove OTU Groups, see page 39, 
“Remove OTU Group”.     

2. Export 
To export OTU Rule Sets, first create OTU groups (for information on how to create OTU groups, 
see page 38, “Create OTU Group and OTU Rule Set”) with the conditions exactly as you wish to 
export.   
 
File → Export → OTU Rule Sets 
Select the desired OTU Rule Sets 

 To export all OTU Rule Sets, click OK without selecting any. Or, click Ctrl-a to easily select all 
OTU Rule Sets before clicking OK. 

Enter desired filter output file name and location 
Click Save 
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IX. Export Data 
 

On occasion it may be useful to export a hierarchy or OTU table for further analysis in a dedicated statistical 
software package such as SAS or R.  To do so, display your data on the Explicet workspace exactly as you 
wish it to appear in the exported spreadsheet (i.e., check library groupings, OTU Start, OTU Width, OTU Last 
functions, etc.), then export to a .txt (tab-separated-value) formatted file. The text file can be imported into a 
variety of programs, including Microsoft Excel, SPSS, R, SAS, JMP, GraphPad, SigmaPlot, etc.  

A. Hierarchy Table 
File → Export → Hierarchy 
Enter desired hierarchy output file name and location 
Click Save 

B. OTU Table 
File → Export → OTU 
A new pop-up window will appear 
Choose the export format 

 Select Entire OTU Name to export the full OTU name, regardless of the current display format. 

 Select Edited OTU Name to export the abbreviated OTU name exactly as it is displayed in the 
current workspace. 

 Choose the OTU Name delimiter (character(s) placed between columns); delimiter may be up 
to 6 characters, enter “tab” for tab. 

 To format the export so that it is compatible for use with the program, R, select Export to R.  
Click OK 
Another pop-up window will appear 
Enter desired OTU export file name and location 
Click Save 
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X. Figures 

A. Pie Charts 
Tools → Plot → Pie Chart 
A new window will appear with the hierarchical data available in the workspace 
Use the drop down arrows to the left of each taxonomic level to find the OTU of interest 
Select the name of the OTU, click Add to Pie (upper right of window) 

 Adjust the display mode using the options in the upper toolbar. See “Display” (page 31) for more 
information.   

 To create sub-wedges in the pie chart (e.g., showing sub-taxa within a phyla), select both the 
phyla and the taxa of interest. 

 The pie chart is composed only of the groups selected by the user. Therefore, it may not add to 
100% unless all the groups are selected. If it is desired that the pie chart sums to 100%, select 
the taxa which are domain level 1 (e.g., “Bacteria”) and any desired phyla, genera, etc.  

 Often the minor components of the dataset are not desired in the pie chart, but the user will 
want to show these as a collapsed “Other” wedge.  To do this, select all of the taxa that you 
want to collapse together, then click Add to Other.  A group named “Other” will appear in the 
table in bold font.  Note: All selected taxa must belong to the same parent-level of taxonomy 
(i.e., they must all share some common higher level of taxonomy).  When you click Add to 
Other, the selected taxa are automatically added to the pie.  Taxa included in collapsed “Other” 
wedge can be viewed by hovering your cursor over “Other”.  To remove the “Other” wedge, 
select “Other” and click Remove from Pie (the taxa is no longer bold and will return to the initial 
individual items). 

The taxa changes to a bold font 

 To remove data, simply select a bold font group, click Remove from Pie.  
Once all the desired taxa are selected, click Plot 
A new window will appear containing pie chart display options 

 To display a single pie chart which includes all libraries’ data, select the Total Libraries 
checkbox 

 To view a pie chart which includes only one specific library’s data, select the library name in the 
column 

 To display a single pie chart which combines data only from the specific libraries selected in the 
column, select Libraries on Plot 

 Up to 16 pie charts (totaled from Total Libraries, Libraries on Plot, and individual  libraries) may 
be created at once 

 Use the Rows and Columns options at the top of the window to adjust the display format 
Click OK to view the pie charts 

 To add/remove taxa, click Done (upper right corner of pie chart window) to return to the 
selection table. 

 To change the display options, click Data (lower right side of pie chart window). 

1. Plot Attributes 
After generating a plot with the default settings, the user can change the appearance of the plot 
through the Plot Attributes button on the lower right side of the plot results window.  

a) Titles / Axes 
Click Titles / Axes tab within Plot Attributes pop-up window 

 Enter a single title for multi-pie charts 

 Sorted libraries have one or more metadata tag(s) pre-appended before the library name, 
separated by a colon. The libraries are then displayed alphabetically first by metadata 
tag(s), then by library name. If Show Library Name is deselected, the library names after 
the colon will disappear, but the metadata tag(s) will remain.  Note: If libraries are not 
sorted and do not have metadata tag(s), then deselecting Show Library Name will not 
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drop the library name (to prevent blank axis labels).  For more information on sorting 
libraries, see page 32, “Sort Libraries”.  

When finished, click Apply in upper right corner of window 

b) Colors 
Click Colors tab within Plot Attributes pop-up window 

 To pick a different background color, click the “…” button and select a new color from the 
pop-up display. 

 To pick a different wedge color, click on the color and select a new color from the pop-up 
display.  

When finished, click Save in upper right corner of window 

c) Legend and Labels 
Click Pie Chart tab within Plot Attributes pop-up window 

 Adjust whether Value, Percentage, and/or Name label the colors represented in the 
legend 

 Adjust the legend Separator if desired 

 Adjust the Legend Location if desired 

 Adjust whether Value, Percentage, and/or Name label the wedges on the pie chart 

 Adjust the pie chart label Separator if desired 

 Adjust the pie chart Label Location if desired 
When finished, click Save in upper right corner of window 

d) Size 
Click Size tab within Plot Attributes pop-up window 
Use the sliders on each axis to adjust the size of the plot as necessary  

 Note:  Does not scale font, only graphics and spacing. 
Click Save to return to the Plot Results window 
Click Print on Plot Results window to access a print preview window with more options 

 Specify the size of the plot in mm or Inches 

 Click Maintain Aspect Ratio to move both sliders together 
Click OK to keep the changes 
 

Note:  Once the size is set in export or printing, it will never be overwritten by the plot attribute 
screen display.  

B. Heatmaps 
Tools → Plot → OTU Heatmap 
A new window will appear with the OTU data table  
To limit the number of OTUs displayed in the heatmap: 

 Select entire dataset by simply clicking Select Range without defining any limiters  

 Manual selection:  click on desired OTUs 

 Select range using limiting boxes on toolbar, then click Select Range:  In the first box, type the 
lower bounding limit.  In the second box, type the upper bounding limit.  Note:  The bounding 
numbers that are selected in the two boxes are dependent upon the current display mode; so 
keep in mind that if the display mode is in Counts, the bounding numbers will include those 
OTUs with corresponding counts/integers.  However, if the display mode is in % of Total, the 
bounding numbers will include those OTUs with corresponding percentages of the total dataset.  

Click Plot on lower right side of window 
A new window will appear containing a list of the individual libraries  

 To display a heatmap which includes all libraries’ data, make sure all libraries are selected.  

 To view a heatmap which includes only one specific library’s data, select the single library name 
in the column. 

 To view a combination of a few libraries, Ctrl-click the individual library names.  
Click OK to view the heatmap 
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 To add/remove taxa, click Done (upper right corner of heatmap window) to return to the 
selection table. 

 To change the included libraries, click Data (lower right side of heatmap window). 

1. Plot Attributes 
After generating a plot with the default settings, the user can change the appearance of the plot 
through the Plot Attributes button on the lower right side of the plot results window.  

a) Titles / Axes 
Click Titles / Axes tab within Plot Attributes pop-up window 

 Enter desired plot and axis titles into the designated spaces 

 Sorted libraries have one or more metadata tag(s) pre-appended before the library name, 
separated by a colon. The libraries are then displayed alphabetically first by metadata 
tag(s), then by library name. If Show Library Name is deselected, the library names after 
the colon will disappear, but the metadata tag(s) will remain.  Note: If libraries are not 
sorted and do not have metadata tag(s), then deselecting Show Library Name will not 
drop the library name (to prevent blank axis labels).  For more information on sorting 
libraries, see page 32, “Sort Libraries”. 

 Adjust axis label rotations as desired 
When finished, click Save in upper right corner of window 

b) Colors 
Click Colors tab within Plot Attributes pop-up window 

 Decrease the number of Color Levels if desired 

 To reverse the colors, click Flip Colors 

 To pick a different color spectrum, click Change Colors and select a new spectrum from 
the pop-up display.  

When finished, click Save in upper right corner of window 

c) Values and Color Bar 
Click Heatmap tab within Plot Attributes pop-up window 

 Deselect Display Heatmap Values to remove the values from the display; specify number 
of Decimal Places in displayed heatmap values 

 Enter desired color bar title 

 Deselect the Autoscale option if desired; change color bar Min/Max 
When finished, click Save in upper right corner of window 

d) Size 
Click Size tab within Plot Attributes pop-up window 
Use the sliders on each axis to adjust the size of the plot as necessary  

 Note:  Does not scale font, only graphics and spacing. 
Click Save to return to the Plot Results window 
Click Print on Plot Results window to access a print preview window with more options 

 Specify the size of the plot in mm or Inches 

 Click Maintain Aspect Ratio to move both sliders together 
Click OK to keep the changes 
 

Note:  Once the size is set in export or printing, it will never be overwritten by the plot attribute 
screen display. 

C. Stacked Bar Charts 
Tools → Plot → OTU Stacked Bar 
A new window will appear with the OTU data table  
To limit the number of OTUs displayed in the chart: 

 Select entire dataset by simply clicking Select Range without defining any limiters  
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 Manual selection:  click on desired OTUs 

 Select range using limiting boxes on toolbar, then click Select Range:  In the first box, type the 
lower bounding limit.  In the second box, type the upper bounding limit.  Note:  The bounding 
numbers that are selected in the two boxes are dependent upon the current display mode; so 
keep in mind that if the display mode is in Counts, the bounding numbers will include those 
OTUs with corresponding counts/integers.  However, if the display mode is in % of Total, the 
bounding numbers will include those OTUs with corresponding percentages of the total dataset.  

Click Plot on lower right side of window 
A new window will appear containing a list of Stacked Bar Modes and the individual libraries  

 Select % of Selected to display only the selected data and create bars of 100% based on the 
relative percentages of the selected OTUs in each bar. 

 Select % of Total to create an “other” category from the non-selected OTUs and create bars of 
100% based on the selected OTUs plus “other” category. 

 Select Counts to display raw data counts in integers. This mode does not force the bars to 
100%.  

 To display a bar chart which includes all libraries’ data, make sure all libraries are selected.  

 To view a bar chart which includes only one specific library’s data, select the single library name 
in the column. 

 To view a combination of a few libraries, Ctrl-click the individual library names.  
Click OK to view the bar chart 

 To add/remove taxa, click Done (upper right corner of bar chart window) to return to the 
selection table. 

 To change the included libraries, click Data (lower right side of pie chart window). 

1. Plot Attributes 
After generating a plot with the default settings, the user can change the appearance of the plot 
through the Plot Attributes button on the lower right side of the Plot Results window.  

a) Titles / Axes 
Click Titles / Axes tab within Plot Attributes pop-up window 

 Enter desired plot and axis titles into the designated spaces 

 Sorted libraries have one or more metadata tag(s) pre-appended before the library name, 
separated by a colon. The libraries are then displayed alphabetically first by metadata 
tag(s), then by library name. If Show Library Name is deselected, the library names after 
the colon will disappear, but the metadata tag(s) will remain.  Note: If libraries are not 
sorted and do not have metadata tag(s), then deselecting Show Library Name will not 
drop the library name (to prevent blank axis labels).  For more information on sorting 
libraries, see page 32, “Sort Libraries”. 

 Deselect the Autoscale option if desired; change axis Min/Max/Step Size 

 Adjust axis label rotations as desired 
When finished, click Save in upper right corner of window 

b) Grid 
Click Grid tab within Plot Attributes pop-up window 

 Deselect Show  to remove the gridlines from the display 

 To change the gridline color, click the “…” button, and select a new color from the pop-up 
display 

 To pick a different gridline pattern, select a new pattern from the Pattern dropdown menu  
When finished, click Save in upper right corner of window 

c) Colors 
Click Colors tab within Plot Attributes pop-up window 

 To pick a different background color, click the “…” button and select a new color from the 
pop-up display. 

 To reverse the colors, click Flip Colors 
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 To pick a different bar color, click on the color and select a new color from the pop-up 
display.  

When finished, click Save in upper right corner of window 

d) Legend and Orientation 
Click Stacked Bar tab within Plot Attributes pop-up window 

 Adjust the orientation of the stacked bars: Horizontal Bars or Vertical Bars 

 Adjust whether the bars are stacked Taxonomies or stacked Libraries  

 Adjust the Gap Width between each stacked bar if desired (set to 0% to make the bars 
touch) 

 Adjust the Legend Location if desired 
When finished, click Save in upper right corner of window 

e) Size 
Click Size tab within Plot Attributes pop-up window 
Use the sliders on each axis to adjust the size of the plot as necessary  

 Note:  Does not scale font, only graphics and spacing. 
Click Save to return to the Plot Results window 
Click Print on Plot Results window to access a print preview window with more options 

 Specify the size of the plot in mm or Inches 

 Click Maintain Aspect Ratio to move both sliders together 
Click OK to keep the changes 
 

Note:  Once the size is set in export or printing, it will never be overwritten by the plot attribute 
screen display.  

D. Manhattan Plots 
These are the plots produced by the Two-Part test, Two-Proportions test, and Wilcoxon test.   

1. Plot Attributes 
After generating a plot with the default settings, the user can change the appearance of the plot 
through the Plot Attributes button on the lower right side of the Plot Results window.  

a) Titles / Axes 
Click Titles / Axes tab within Plot Attributes pop-up window 

 Enter desired plot and axis titles into the designated spaces 

 Sorted libraries have one or more metadata tag(s) pre-appended before the library name, 
separated by a colon. The libraries are then displayed alphabetically first by metadata 
tag(s), then by library name. If Show Library Name is deselected, the library names after 
the colon will disappear, but the metadata tag(s) will remain.  Note: If libraries are not 
sorted and do not have metadata tag(s), then deselecting Show Library Name will not 
drop the library name (to prevent blank axis labels).  For more information on sorting 
libraries, see page 32, “Sort Libraries”. 

 Adjust whether the display is Linear or Log 

 Deselect the Autoscale option for each axis if desired; change axis Min/Max/Step Size 

 Adjust axis label rotations as desired 
When finished, click Save in upper right corner of window 

b) Grid 
Click Grid tab within Plot Attributes pop-up window 

 Deselect Show  to remove the gridlines from the display 

 To change the gridline color, click the “…” button, and select a new color from the pop-up 
display 

 To pick a different gridline pattern, select a new pattern from the Pattern dropdown menu  
When finished, click Save in upper right corner of window 
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c) Colors 
Click Colors tab within Plot Attributes pop-up window 

 To pick a different background color, click the “…” button and select a new color from the 
pop-up display. 

 To pick a different curve color, click on the color and select a new color from the pop-up 
display.  

When finished, click Save in upper right corner of window 

d) Legend and Labels 
Click Curves tab within Plot Attributes pop-up window 

 Adjust the Legend Location if desired  

 Adjust the Curve Width if desired 

 Adjust the Line Marker Width if desired 

 Adjust the marker Symbol if desired 

 Select Display error bars if desired 

 Deselect Display marker at rarefaction point to remove the line markers from the 
display 

When finished, click Save in upper right corner of window 

e) Size 
Click Size tab within Plot Attributes pop-up window 
Use the sliders on each axis to adjust the size of the plot as necessary  

 Note:  Does not scale font, only graphics and spacing. 
Click Save to return to the Plot Results window 
Click Print on Plot Results window to access a print preview window with more options 

 Specify the size of the plot in mm or Inches 

 Click Maintain Aspect Ratio to move both sliders together 
Click OK to keep the changes 
 

Note:  Once the size is set in export or printing, it will never be overwritten by the plot attribute 
screen display. 

E. Print 
To print a plot, click Print on the lower right side of the Plot Results window 
A print preview window with more options will appear 

 Specify the size of the plot in mm or Inches 

 Click Maintain Aspect Ratio to move both sliders together 
Click Print  
Choose a printer and any desired printer settings, then click Print 

 
Note:  Once the plot size is set in export or printing, it will never be overwritten by the plot attribute 
screen display.  

F. Export 
Explicet can export graphics images in either bit mapped (.bmp) or vector (.ps and .pdf) formats. 
 
Vector formats can be rescaled (made larger or smaller) to any size with software tools like Adobe 
Illustrator or GIMP (GNU Image Manipulation Program).   For simple display at the original size in 
Microsoft Word or PowerPoint, the .bmp format is fine.  For significant changes in aspect ratio, such as 
when creating an image for a small figure in a publication, Illustrator/GIMP will likely be needed to 
maintain the relative proportionality of all of the elements of a graphic.   
 
Note:  Explicet’s scaling capability in Print preview (see page 48) is limited to scaling the graphical 
elements only; the font size is fixed.  Illustrator/GIMP is required when both graphical elements and font 
size need to change in concert. 
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1. Spreadsheets (Graphics Setup) 
The data that form the basis for any graphic can be exported as a tab-delimited (.txt) file. 
 
Click Export on lower right side of the graphic setup window 
A new pop-up window will appear 
Choose the export format 

 Select Entire OTU Name to export the full OTU name, regardless of the current display 
format. 

 Select Edited OTU Name to export the abbreviated OTU name exactly as it is displayed in 
the current workspace. 

 Choose the OTU Name delimiter (character(s) placed between columns); delimiter may be 
up to 6 characters, enter “tab” for tab. 

 To format the export so that it is compatible for use with the program, R, select Export to R.  
Click OK 
Another pop-up window will appear 
Enter the desired export file name and location 
Click Save 

2. Graphics (Plot Results) 
Graphics output by Explicet may be in either bit-map formats (such as .png) or vector formats (.pdf), 
which are readily imported by tools such as Microsoft Word, PowerPoint, and Adobe Illustrator.   

 
Click Export in lower right corner of Plot Results window 
A new pop-up window will appear 
Enter the desired export file name and location 
Select the type of file you wish to export (.pdf, .ps, or image options)  
Click Save 

G. Save as Figure 
Similar to workspaces, figures are saved within the larger project, so they stay linked to the data from 
which they were created and do not create additional files on your computer.  
 
Click Done in Plot Results window 
Click Save as Figure in lower right corner of plot setup window 
Enter the desired figure name 
Click OK 

1. Open Existing Figure 
There are 2 different ways to open a figure: 
1. Tools → Figures  
2. Click the Figures button in the upper right corner of the project window.   
 
A pop-up window will open with the list of existing figures and associated specs.  The column 
headings can be clicked to re-sort the list of figures according to Plot Type, Filter, Workspace, date 
Created, etc.  From this window, figures can be opened, deleted, or renamed.  Double-clicking on a 
figure name immediately opens the figure in its original workspace.  By clicking Open in Different 
Workspace, the user can open a figure in a workspace other than the one in which it was created; 
opening a figure in a different workspace keeps both the original figure in the original workspace and 
creates a new figure in the newly selected workspace.   
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XI. Statistics 
 
For more comprehensive information on ecological statistics please see Magurran [6] and Colwell [3]. 

A. Alpha Diversity 
The alpha diversity metrics address species diversity of Explicet libraries.  When comparing alpha 
diversity metrics between libraries of different sizes (different numbers of total counts per library), 
rarefaction is essential.  Rarefaction is a process that randomly resamples all libraries to the sampling 
depth of the smallest library (called the rarefaction point), thus allowing the alpha diversity metrics to be 
compared directly. The curves generated by plotting the alpha diversity metrics versus sample size are 
called collectors curves and are indicative of how well-sampled libraries are.  Species observed (Sobs) 
is a metric which provides a good intuitive example of how to interpret collectors curves.  If a Sobs 
graph has a steep upwards slope at the terminal end of the curve, it indicates that additional taxa are 
likely to be found with a small amount of additional sampling effort.  If the Sobs curve flattens out, a 
sufficient number of samples have likely been taken as no more taxa will be found with additional 
sequencing.    
 
Tools → Analyze → Alpha Diversity 
A new pop-up window will appear 

1. Settings 

a) Libraries 
The user can select whether to calculate diversity for all the libraries, a subset of libraries, or 
groups of libraries by clicking on the various options at the top and right of the pop-up window.  
For descriptions of these options, see page 31, “Display”. 

b) Bootstrap 
Bootstrap is a way to estimate standard error for complex parameters and a way to check the 
constancy of results.  It sets the number of iterations that a set of calculations will be repeated for 
alpha diversity estimation.  Bootstrap is the name of the process that Explicet uses to provide 
rarefaction for the alpha diversity metrics.  Clicking on the Bootstrap button causes Explicet to 
start the random resampling process. At rarefaction, Bootstrap is resampled to the size of the 
smallest library.   
   
Default: 25. The dataset will be resampled 25 times.   

c) Cutoff Size 
Varies by dataset. The default will select all libraries ≥ the 3rd sigma of the average library size 
value.  Some very small libraries may be excluded, which will be displayed directly to the right of 
the Cutoff Size box. 

d) # Steps 
In generating a collector’s curve, the step size controls the incremental increase in number of 
sequences between resampling events, in other words the number of data points in each curve. 
The number of sequences in the smallest included library is divided by # Steps to create the step 
size.  This step size will then be applied to all the larger libraries for calculations and rarefaction.  
The number of sequences per step is displayed to the right of the # Steps box. 
 
Default: 0 steps.   

 By default, Explicet calculates a Single statistic at Rarefaction point only.  To remove 
this default, deselect the checkbox below the # Steps box.    

 To create collector’s curves, begin small at # Steps: 10; as the # Steps increases, 
Bootstrap will take longer to run.  To create smoother curves, increase # Steps, but keep 
in mind that the length of time to run Bootstrap will increase exponentially.  
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e) Use Min Lib Size 
Using the minimum library size is necessary for comparison of multiple curves/libraries.  Most 
studies will have this option checked; Use Min Lib Size should be checked to reduce bias. For 
example, if you have one library with 500 sequences and another library with 10,000 sequences, 
the value at rarefaction is where the smallest library size falls; this way, the libraries are 
compared at the same level of sampling effort.     
 
You may choose to un-check Use Min Lib Size if you’re looking at individual libraries 
irrespective of other libraries.  Without Use Min Lib Size checked, sampling starts at each 
library’s total Counts divided by 10 (when # Steps: 10).  Note that if this option is not selected, 
rarefaction will not apply due to sampling variation/sampling bias between libraries.        

f) User Modifications 
The user may modify any of the default settings to be more or less stringent.  

2. Calculate 
After selecting all the appropriate settings, click Bootstrap on upper right side of window.  This will 
generally take a few seconds to minutes depending on computer processing speed.  You will be 
unable to use other Explicet functions while the program is calculating alpha diversity. 

3. Tests 

a) Sobs 
The number of taxa/OTUs observed in a library. 

b) Singletons 
The number of taxa/OTUs observed exactly once in a library. 

c) Doubletons 
The number of taxa/OTUS observed exactly twice in a library. 

d) ACE 
Abundance based Coverage Estimator.  The number of predicted taxa/OTUs based on observed 
singletons and rare taxa. 

e) ACEVar 
Coefficient of variation of the Abundance based Coverage Estimator. 

f) Chao1 
The number of species predicted based on observed singletons and doubletons. 

g) Chao195ciL 
Chao1 lower 95% confidence interval based on the bootstrap. 

h) Chao195ciU 
Chao1 upper 95% confidence interval based on the bootstrap. 

i) Goods 
A measure of how well the amount of sequencing done for a library represents the biodiversity in 
the library.  Low coverage means that the library is under-sampled and may require additional 
sequencing.  “Good’s Coverage” is measured on a 0-100% scale, with 100% indicating that all 
expected OTUs have been observed.   

j) ShannonH 
Shannon diversity index, H (log base 2).  This measure of biodiversity incorporates both OTU 
richness and OTU evenness into a single value.  Greater OTU count and more uniform 
distribution of OTUs increase H.  
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k) ShannonE 
Shannon evenness index, H/Hmax (log base 2).  Measures the uniformity of a distribution of 
OTUs on a 0-100% scale.  A perfectly uniform distribution will have E = 100%.   

l) Simpson 
Simpson’s index, D:  Another measure of complexity that measures the probability that two 
randomly selected individuals belong to the same OTU. 

m) SimpsonD 
Simpson’s diversity index: 1 – D. 

n) SimpsonE 
Simpson’s evenness index.                           

o) SimpsonR 
The reciprocal of Simpson’s index: 1/D. 

4. Plot 
After calculating the alpha diversity, click Plot on lower right side of window. A pop-up will appear 
with all the diversity measures and library names. Select the desired parameters, then click OK to 
plot the rarefaction curves for the selected measure and libraries.  See page 43 for details on how to 
modify titles, axis labels, and colors. 

B. Beta Diversity 

1. Tests 

a) Morisita-Horn 

                  
∑
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SA,i = the number of individuals from community A in the ith OTU 
AB,i = the number of individuals from community B in the ith OTU 
n = the number of individuals in community A 
m = the number of individuals in community B 

 
(Formula from Mothur website: http://www.mothur.org/wiki/Morisitahorn) 

 
Morisita-Horn is a beta diversity measure on a 0-1 scale, indicating relative similarity between 
OTUs contained within two libraries; 1 = identical overlap in OTUs between libraries, 0 = no 
shared OTUs between two libraries. 
 
Tools → Analyze → Beta Diversity → Morisita-Horn 
A new window will appear that contains a comparison matrix with the calculated Morisita-Horn 
values for each pair of libraries or metadata groupings.  A value of 1.000 indicates two groups 
are identical, which is why the diagonal of the matrix (libraries compared to themselves) has 
values of 1.000. 

b) Bray-Curtis 
 

                
∑   (         )

∑     ∑    
  

 
SA,i = the number of individuals in the ith OTU of community A 
AB,i = the number of individuals in the ith OTU of community B 

 

http://www.mothur.org/wiki/Morisitahorn
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(Formula from Mothur website: http://www.mothur.org/wiki/Braycurtis) 
 

 
Bray-Curtis is a beta diversity measure on a 0-1 scale, indicating relative dissimilarity between 
OTUs contained within two libraries; 0 = identical overlap in OTUs between libraries, 1 = no 
shared OTUs between two libraries. 
 
Tools → Analyze → Beta Diversity → Bray-Curtis 
A new window will appear that contains a comparison matrix with the calculated Bray-Curtis 
values for each pair of libraries or metadata groupings.  A value of 0.000 indicates two groups 
are identical, which is why the diagonal of the matrix (libraries compared to themselves) has 
values of 0.000. 

c) ThetaYC 
 

       
∑     
  
   

∑ (     )
  ∑     

  
   

  
   

  

 
ST = the total number of OTUs in communities A and B 
ai = the relative abundance of OTU i in community A 
bi = the relative abundance of OTU i in community B 

 
(Formula from Mothur website: http://www.mothur.org/wiki/Thetayc) 

 
ThetaYC is a beta diversity measure on a 0-1 scale, indicating relative dissimilarity between 
OTUs contained within two libraries; 0 = identical overlap in OTUs between libraries, 1 = no 
shared OTUs between two libraries. 
 
Tools → Analyze → Beta Diversity → ThetaYC 
A new window will appear that contains a comparison matrix with the calculated ThetaYC values 
for each pair of libraries or metadata groupings.  A value of 0.000 indicates two groups are 
identical, which is why the diagonal of the matrix (libraries compared to themselves) has values 
of 0.000. 

2. Display Options 
The matrix display, and subsequent plots, can be modified by rearranging libraries to group by 
higher values in either the upper left (Descending by Value) or lower right (Ascending by Value) 
corner.  The default order is Alphabetical by Library Name, which can be useful if libraries within a 
metadata group are defined by similar names. 

3. Plot 
A heatmap of the matrix is generated by clicking Plot on the lower right side of window. See the 
section on heatmaps (page 44) for information on modifying the plot attributes. 

C. Two-Part Test 
This tool provides a statistical test of whether each OTU differs significantly between two groups of data.  
The Two-Part test is the sum of two test statistics, one comparing the proportion of non-zero counts 
and one comparing the medians of the non-zero counts. The statistical approaches incorporated in 
Explicet are useful for identification of taxa that differentiate two groups. The Two-Part statistic makes 
use of a common practice in statistics by adding the Chi2 statistics from two independent tests. This 
was developed to address the issue of inverse relationship between proportion of samples that 
contained a taxon and the median relative abundance of that taxon.  For more information on the Two-
Part test, please see: Wagner et al [11]. 
 

http://www.mothur.org/wiki/Braycurtis
http://www.mothur.org/wiki/Thetayc
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The input requires that the user select two mutually exclusive categories of libraries (e.g., healthy and 
diseased) using filters.  To create filters see page 37, “Select Libraries”.  The developers recommend 
that at least five libraries be in each category so that the test is statistically valid. 
 
 
Tools → Analyze → Two-Part 

1. Settings 

a) Select Filters 
The number of libraries included in each filter will be displayed immediately to the right of the 
filter selection.  If no filters have been created, click Setup Filters on upper right side of window 
and proceed as described on page 37, “Select Libraries”. 

b) Select P-Threshold 
Default: 0, which will show the P-value for every OTU. 

c) OTU Display 
Select the desired OTU name display options, see page 31 for details. 

2. Output 
The output table displays the following variables with values for each of the taxa: m1, p1, med1, m2, 
p2, med2, chi2 (chi**2), PValue and -Log(PV)… 

a) m1 and m2 
The number of samples with non-zero sequence counts for each category.  

b) p1 and p2 
The % of non-zero counts for each corresponding group:  p1 and p2 are the prevalences of an 
OTU in the two categories.  

c) med1 and med2 
The median of the non-zero sequence counts (or median of the “m” samples). 

d) chi**2 
The chi-squared test statistic for the two-part test. 

e) PValue 
The corresponding parametric p-value from the two-part test. 

f) -Log(PV) 
The negative of the log(base 10) of the p-value.  This transformation is used to easily see those 
taxa which are statistically significant in the Manhattan plot. 

3. Plot 
Once Two-Part statistics have been calculated, the data can be visualized as a Manhattan plot 
(scatterplot with lines) by clicking Plot on lower right side of window.  The x-axis is the OTU number 
from the Two-Part spreadsheet; the y-axis is the -Log(PV).  The plots have three horizontal marker 
lines.  The bottom line indicates results approaching significance at a p-value of 0.1.  The middle line 
denotes significance at a p-value of 0.05, and the top line denotes significance at a p-value of 0.01.   
 
See page 43 for details on how to modify titles, axis labels, and colors.  

D. Two-Proportions Test 
The Two-Proportions test identifies the differences in proportion between two populations.  This 
comparative tool performs a continuity-adjusted chi-square test to evaluate the difference in the 
detection rates across the two groups for each taxa/OTU.  
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The input requires the user to apply two mutually exclusive filters to the libraries tested. To create filters 
see page 37, “Select Libraries”. 
 
Tools → Analyze → Two-Proportions 

1. Settings 

a) Select Filters 
The number of libraries included in each filter will be displayed immediately to the right of the 
filter selection.  If no filters have been created, click Setup Filters on upper right side of window 
and proceed as described on page 37, “Select Libraries”. 

b) Select P-Threshold 
Default: 0, which will show the P-value for every OTU. 

c) OTU Display 
Select the desired OTU name display options, see page 31 for details. 

2. Output 
The output table displays the following variables with values for each of the taxa: m1, p1, m2, p2, Z, 
PValue and -Log(PV)… 

a) m1 and m2 
The number of samples with non-zero sequence counts for each corresponding group.  

b) p1 and p2 
The % of non-zero counts for each corresponding group.  

c)  Z 
The two-proportions value. 

d) PValue 
The corresponding parametric p-value from the two-proportions test. 

e) -Log(PV) 
The negative of the log(base 10) of the p-value.   

3. Plot 
Once Two-Proportion statistics have been calculated, the data can be visualized as a Manhattan plot 
(scatterplot with lines) by clicking Plot on lower right side of window.  The x-axis is the OTU number 
from the Two-Proportion spreadsheet; the y-axis is the -Log(PV).  The plots have three horizontal 
marker lines.  The bottom line indicates results approaching significance at a p-value of 0.1.  The 
middle line denotes significance at a p-value of 0.05, and the top line denotes significance at a p-
value of 0.01.  
 
See page 43 for details on how to modify titles, axis labels, and colors.  

E. Wilcoxon Test 
The Wilcoxon test is a nonparametric statistical calculation used to compare the median OTU 
abundances of two categories.  A non-parametric Wilcoxon test with a continuity correction is employed 
because OTU abundances are not necessarily normally distributed. This version of the Wilcoxon test 
compares the median relative abundance from all samples. This differs from the Wilcoxon test used in 
the Two-Part test, which includes only samples with median relative abundances greater than 0.0.  
 
The input requires the user to apply two mutually exclusive filters to the libraries tested. To create filters 
see page 37, “Select Libraries”. 
 
Tools → Analyze → Wilcoxon 
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1. Settings 

a) Select Filters 
The number of libraries included in each filter will be displayed immediately to the right of the 
filter selection.  If no filters have been created, click Setup Filters on upper right side of window 
and proceed as described on page 37. 

b) Select P-Threshold 
Default: 0, which will show the P-value for every OTU. 

c) OTU Display 
Select the desired OTU name display options, see page 31 for details. 

2. Output 
The output table displays the following variables with values for each of the taxa: m1, n1, p1, med1, 
m2, n2, p2, med2, W, PValue and -Log(PV)… 

a) m1 and m2 
The number of samples with non-zero sequence counts for each corresponding category.  

b) n1 and n2 
The total number of samples in each category.  

c) p1 and p2 
The % of non-zero counts for each corresponding category.  

d) med1 and med2 
The median of the non-zero sequence counts (or median of the “m” samples). 

e) W 
The Wilcoxon value.  

f) PValue 
The parametric p-value from the two-part test. 

g) -Log(PV) 
The negative of the log(base 10) of the p-value.  This transformation provides a convenient 
means of plotting p-values, such as in a Manhattan plot. 

3. Plot 
Once Wilcoxon statistics have been calculated, the data can be visualized as a Manhattan plot 
(scatterplot with lines) by clicking Plot on lower right side of window.  The x-axis is the OTU number 
from the Wilcoxon spreadsheet; the y-axis is the -Log(PV).  The plots have three horizontal marker 
lines.  The bottom line indicates results approaching significance at a p-value of 0.1.  The middle line 
denotes significance at a p-value of 0.05, and the top line denotes significance at a p-value of 0.01.   
 
See page 43 for details on how to modify titles, axis labels, and colors.  
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XII. Comparing Two-Part, Two-Proportions, Wilcoxon Tests 
 
The following table documents under which conditions results for each of the comparative tests will be 
obtained. 
 

Conditions 
Two-Part Two-Proportions Wilcoxon 

Category 1 Category 2 

m1 = 0 m2 = 0 --- --- --- 

m1 ≤ 1 m2 > 1   --- 

m1 > 0 m2 ≤ 1   --- 

m1 >1 m2 > 1    

 
The following plot and chart demonstrate how to decide which of the three tests (Proportion, Wilcoxon, Two-
Part) holds the most power for an individual dataset.  For more information on how this plot was created, 
please view the Explicet Tutorial.  The tutorial and associated data are obtainable from the website: 
www.wally.colorado.edu/Explicet    
 

 
 
The points farthest from the origin are labeled.  The names in black were identified as significant; the points 
with grey text were not statistically significant.  The two greyed out quadrants are situations in which the Two-
Part test has power to identify significant differences (where the component statistics lose power due to the 
inverse relationship between proportion and relative abundance average out). While Finegoldia has a large 
change in relative abundance this is due to detection at ~41% relative abundance in a single umbilicus library. 
These data can be simplified by excluding taxa not present in a majority of libraries from either group. This 
graphic was generated by exporting the Two-Part test statistic data from Explicet and processing in Microsoft 
Excel.  

Corynebacterium 

Finegoldia 

Propionibacterium 

http://www.wally.colorado.edu/Explicet
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Explicet Directory 
 

 
  

Code Label Function 

A File New: Project (pg. 34), Project from Current Project (pg. 34), Workspace (pg. 36), 
Workspace from Current Workspace (pg. 36) 

    Open: Project (pg. 34), Workspace (pg. 36) 
    Close: Project (pg. 34), Workspace (pg. 36) 
    Save (pg. 34) 
    Save As (pg. 34) 
    Delete Workspace (pg. 36) 

    
Import: File (pg. 24), Directory (pg. 25), Metadata (pg. 28), Filters (pg. 41), OTU 
Rule Sets (pg. 41) 

    
Export: Hierarchy (pg. 42), OTU (pg. 42), Metadata (pg. 29), Filters (pg. 41), OTU 
Rule Sets (pg. 41) 

    Exit (pg. 34) 

B Edit Project Settings (pg. 34) 

C Data Select Libraries (pg. 37) 
    Remove Libraries (pg. 27) 
    Rename Libraries (pg. 27) 
    Metadata (pg. 28) 
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D Group Group Libraries (pg. 38) 
    Group OTU (pg. 38) 
    Ungroup OTU (pg. 39) 
    Add OTU Names to OTU Group (pg. 39) 
    Remove OTU Names from OTU Group (pg. 39) 
    Rename Group (pg. 40) 
    Workspace / OTU Rule Set Manager (pg. 40) 
    Edit OTU Rule Sets (pg. 40) 

E Tools Analyze: Alpha Diversity (pg. 50), Beta Diversity (pg. 52), Two-Part (pg. 53), Two-
Proportions (pg. 54), Wilcoxon (pg. 55) 

    Plot: Pie Chart (pg. 43), OTU Heatmap (pg. 44), OTU Stacked Bar (pg. 45) 
    Figures (pg. 49) 

F View Sort Libraries (pg. 32) 
    Unsort OTU (pg. 33) 

G Help About 

H Project displays current Project name (Projects, pg. 34) 

I Workspace displays current Workspace name (Workspaces, pg. 36) 

J Current Filter displays current Filter name (Filters, pg. 37) 

K Hierarchy displays Hierarchy pane only (pg. 31) 

L OTU displays OTU pane only (pg. 31) 

M Both displays Hierarchy and OTU panes (pg. 31) 

N Counts displays raw sequence data counts in integers (pg. 31) 

O % of Library displays data normalized by column (pg. 31) 

P % of Total displays data normalized to total dataset (pg. 31) 

Q OTU Start taxonomic level to start lineage lines in OTU pane (pg. 31) 

R OTU Width width of number of lineage levels selected (pg. 31) 

S 
OTU Show 
Last appends last item in taxonomic line onto truncated OTU lineage (pg. 31) 

T 
Hierarchy 
Level sets default number of taxonomic levels expanded in hierarchy pane (pg. 32) 

U 
Show 
Libraries displays the libraries by name and sorts them alphabetically (pg. 32) 

V 
Show Sorted 
Libs displays libraries alphabetically first by metadata tag, then by library name (pg. 32) 

W 
Show Lib 
Groups 

displays combined OTU counts from all libraries within selected metadata group 
(pg. 32) 

X All Libraries displays all libraries in the workspace based on sort/group selections (pg. 32) 

Y 
Selected 
Libraries displays only the libraries included in the current filter (pg. 32) 

Z # Libraries number of libraries displayed 

AA Figures click to view the list of figures within the project (Figures, pg. 49) 

BB 
Close 
Workspace click to close the workspace 

CC Save click to save the project 

DD Close Project click to close the project 

EE Hierarchy data collapsed into taxa with triangular expansion buttons - clicking on an 
expansion button expands only the selected phyla to the next taxonomic level (pg. 
31) 

FF Total displays the total for each taxa in "EE" (Raw and Normalized Data Options, pg. 31) 

GG Library Name displays each library and its individual total for each taxa in "EE" 

HH 
Hierarchy 
Pane displays data collapsed into taxa with triangular expansion buttons (pg. 31) 

II OTU 
displays each taxonomic classification listed individually, often resulting in very 
long OTU names (pg. 31) 



© 2012-2013 Charles E. Robertson and Incubix, Inc.                                                                                                   60     
                               

JJ OTU Rule Set click to view the OTU Rule Set definition and its members (pg. 40) 

KK Total displays the total for each taxa in "II" (Raw and Normalized Data Options, pg. 31) 

LL Library Name displays each library and its individual total for each taxa in "II"  

MM OTU Pane displays each taxonomic classification listed individually (pg. 31) 
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